Quantcast
Jump to content

  • Sign Up, it's FREE!

    Welcome to RC Drone Forum! Use the main menu and search bar to navigate our site. It's always FREE to join our Drone Community and post in our forums, create your own Drone club, share your photos and videos and more. It's easy to get started and you can login with some of these popular social networks.

Fly4Jesus

Holy Stone 700D- a little help

Recommended Posts

Hi Drone flyers, 

  My name is Colin. I just got an HS 700D. I like it a lot.  I have a quick "what in the world is going on" question. 

 Whenever I hit the return to home button it goes straight up in the air instead of coming down. 

Any help on this?

  • Like 1

Share this post


Link to post
Share on other sites


I Colin,

I also own a HS 700D.  I haven't had any problems with the return to home.  What I'm having problems with getting to work is the follow me feature.  So maybe we could help each other out?😉

What I have noticed is that I need to do a gyro calibration after each time I power off the drone.  Are you able to successfully do the gyro calibration?  Before you take off, the front lights should be solid red and the rear lights should be solid green.  I also notice where I fly I typically get 15-17 satellites locked on.  How many satellite locks are you seeing on your remote?

Just an observation.  When I press the return to home button on the remote, it will immediately start coming back to the location where I took off at, but when it reaches that area it will tend to hover for some time before it starts to descend for landing but if I wait long enough, it does gradually start to descend and land.

Is follow me been working for you?

  • Like 1

Share this post


Link to post
Share on other sites

HI Rendroll,

       I'm able to do a successful calibration. After hearing from you, I'm thinking my RTH is broken.  I don't use the Follow Me function. I'm mostly sitting due to being in a wheelchair mostly.

Have fun flying!

  • Like 1

Share this post


Link to post
Share on other sites

Just out of curiosity and possible further trouble shooting, have you tried the RTH on the Ophelia app screem as well as the remote?

Just thinking, maybe there's the possibility of just a problem with the remote RTH button.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...